Macでdyld: Library not loaded: /usr/local/opt/openssl/lib/libssl.1.0.0.dylib

Macでjupyter notebookを実行しようとしたら表題のエラー

opensslが見つからないらしい

Homebrewでインストールすると解決したという記事をみつけたのでやってみた

brew update

# 以下のどちらか
brew install openssl
brew reinstall openssl

しかし上手く行かなかった

どうやら最新版のopensslが入ってしまってダメらしい

brew switch openssl 1.0.2s

古いバージョンを指定してやると、jupyterが上手く動いた

参考

dyld: Library not loaded: /usr/local/opt/openssl/lib/libssl.1.0.0.dylib - Stack Overflow

コメント

タイトルとURLをコピーしました